Author Topic: "Linker command failed..." in SimulatorDemo  (Read 7807 times)

ChrisDev

  • Newbie
  • *
  • Posts: 2
    • View Profile
"Linker command failed..." in SimulatorDemo
« on: August 26, 2015, 04:17:42 PM »
Hi,

I downloaded your sample code, but "SimulatorDemo" has a "build failed" error. Reinstalled Xcode 6.4 (6E35b), but still failing! (MasterDetailDemo build succeeds)

I downloaded your Book 3 on iBooks: "Mastering Xcode 6 & Swift" - why do you refer to 2 different books on your website: Book 3: "Navigating Xcode 6" and Book 4: "Learn to Code in Swift"? 

Thanks!
Chris

kjmcneish

  • Administrator
  • *****
  • Posts: 719
    • View Profile
Re: "Linker command failed..." in SimulatorDemo
« Reply #1 on: August 26, 2015, 05:48:28 PM »
Chris,

Thanks for the heads up! I was able to reproduce the problem...looks like the project file became corrupt somewhere along the line.

ANYWAY, I have uploaded a new version of the project to our site, and all should be good. Sorry for the inconvenience!

http://www.iOSAppsForNonProgrammers.com/SamplesXC8.html

Regarding the books, we are in the process of reworking the series. We have renamed "Navigating Xcode 6" to "Master Xcode 6 & Swift". This book used to be in Objective-C, but the updated version is now in Swift. We're still in the process of creating the Kindle and paperback versions of these books and will update the web site when they are complete. Book 4: Learn to Code in Swift is a separate book specifically about Swift.

All the best!
Kevin
« Last Edit: August 26, 2015, 05:50:48 PM by kjmcneish »

ChrisDev

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: "Linker command failed..." in SimulatorDemo
« Reply #2 on: August 27, 2015, 12:26:31 AM »
Thanks so much, Kevin! :)